Destination address not allowed
When attempting to configure, or deploy to a server using the DeployHQ agent, you may run into the following error:
Destination address not allowed
This happens when you're trying to connect to a server that isn't permitted to connect via the Agent.
In order to connect to another machine in your network, you'll need to add its local IP address to ~/.deploy/agent.access on the machine running the agent.
Entries in agent.access must be IP addresses or CIDR ranges. Hostnames are not supported and are silently ignored, so an entry such as server.local will not permit anything — add the machine's IP address, or a CIDR range that covers it, instead.
After changes are made to agent.access, you'll need to restart the agent.