Header

Node Sass does not yet support your current environment

During your initial build command, most commonly when running npm install, you might run an error similar to the following:

Error: Node Sass does not yet support your current environment: Linux 64-bit with Unsupported runtime

This most likely means, you're running a higher version of node than supported by your environment.

The versions and their supported environments can be found here.

  • But why does it work locally when I run npm install?

You might indeed find that this works locally when you run the same commands - the first thing to check is what language version you're running locally.

You may need to downgrade your language version within your DeployHQ project, to match the version running locally:

https://your-domain.deployhq.com/projects/your-project/build_configuration

If you've made changes to the language version, it would be wise to clear your build cache before your next deployment.